Supported browsers

We support the current and previous major releases of the following browsers:

Using older browser versions can prevent you from accessing Forumbee, and some site features won't function as expected. Using the latest browsers also provide better encryption and privacy support.

For the best site experience, we recommend downloading the latest version from any of the sites listed above. Check out this site to view the latest versions of the browsers.

 

Internet Explorer Users:  Support is provided for Internet Explorer 11. Previous versions have only limited support and are not recommended.

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
Like Follow
  • 1 yr agoLast active
  • 1044Views
  • 2 Following